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Introduction
This chapter explains how to start up Supervisor, and provides an overview of its 
basic elements, menus, and commands. 

Supervisor provides a “window” into a Mercury-based system by displaying the 
activity of a subset of CEs at several levels of detail. You can also use Supervisor 
to suspend, resume, kill, and debug individual processes on the runtime Mercury 
host.

Starting Up Supervisor
You must run Supervisor from a development host system, which is the system on 
which you installed the Mercury DEVOS package (such as DEVNT). You will use 
Supervisor to connect to a runtime host system, which is your Mercury-based host 
system. To avoid confusion, the Mercury system will always be referred to as the 
runtime host system or the Mercury system. You can install your development envi-
ronment, including Supervisor, on a runtime host system, which combines the 
development host and the runtime host on a local host system.

Note: Mercury does not support using Exceed to run Supervisor remotely on a Solaris-
based development from a Windows environment. However, if you choose to use 
Exceed, make sure you use version 7.0 and above. Earlier versions have shown 
intermittent problems with, among other applications.

� Before starting up Supervisor:

1. Make sure rspmc is running on the runtime host system.

2. If the runtime host system is using VxWorks instead of MC/OS, start the 
Tools Server (tssmc) on the runtime host, and leave it running in the back-
ground. Refer to the VxWorks documentation for more information about 
running background processes in its environment.

3. Make sure that configmc init has been successfully executed on the 
runtime host system and it has built the configuration database.
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Do not use the -nbi switch, and do not issue a configmc reset command 
while Supervisor is running. For details about configmc, see the Mercury 
System Manager’s Guide.

� To start Supervisor and connect to a runtime host system:

1. For the Windows NT and Windows 2000 platforms:

• From the Start menu, choose Run... and browse to the directory in which 
you installed Supervisor.exe. Click OK to launch the application.

Note: You can create a desktop shortcut for Supervisor, or you can add it to the
Start > Programs menu. Refer to your Windows documentation for more 
information.

2. For the Solaris platform:

• At the command prompt, enter supervisor & .

Note that the installation program modified your path to include Super-
visor, so there is no need to change directories.

Supervisor displays an empty main window and immediately opens the 
Connect dialog box, as shown in Figure 2-1:

3. Enter the name or IP address of the runtime Mercury system and click 
Connect.

For example:

Figure 2-1. Initial Window
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• IP address—138.36.123.521

• Full system name—system1.mc.com

• Short system name (from within a network)—system1

Note: If you close the Connect dialog box before you make a connection to a runtime 
Mercury system, most of Supervisor will be unavailable. You will only be able to 
make changes to the fields in the Options dialog box, the User Preferences dialog 
box, and/or the Customization dialog box.

When the first connection is established, Supervisor displays the runtime system 
tree, expanded to CE level, in the left pane of the main window. The right pane 
displays information about the runtime host system in the CE View, as shown in 
Figure 2-2. 

Figure 2-2. CE View at start-up
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The last View left open before exiting Supervisor is stored with the user’s profile. 
It becomes the starting View for the next Supervisor session for that user.

Choosing a Runtime Host 
The first time you use Supervisor, enter the name of the runtime host system by 
typing it into the Host field, as described in the previous section. Supervisor stores 
the names of up to six runtime hosts in a drop-down list attached to the Host field. 
Optionally, you can set up a default runtime host system that Supervisor will 
display at startup. 

If there is no default runtime host system set and this is not the first Supervisor 
session, the Host field is pre-filled with the runtime host system from the most 
recent connection. You can enter a new runtime host, or choose from the drop-
down list as it accumulates data.

If you want to connect to a different runtime host during a Supervisor session, 
you must disconnect from the active runtime host as described in “Disconnecting 
from a Runtime Host System”, before you can connect to another runtime host.

� To set a default runtime host system:

1. Click the Connect button in the toolbar or choose File > Connection... .

The Connect dialog box appears.

2. Enter the name of the runtime host system, or choose its name from the drop-
down list, then click the Use as default checkbox.

All subsequent Supervisor sessions will fill the Host field of the Connect 
dialog box with the default runtime host.

 Keep in mind that when you open a new Supervisor window, as explained in 
“Opening More Supervisor Windows,” it is part of the same Supervisor 
session, and is connected to the same runtime host.

Note: If there is no default runtime host set, and MC_remote_host is set on the 
development host, Supervisor fills the Host field with the value for 
MC_remote_host.

 A default host configured with the Connect dialog box takes precedence over 
any previous value of MC_remote_host. 
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About the Main Window 

The Supervisor Main Window displays information about the runtime host 
system at different levels of detail, depending on which item is selected, which 
view you choose, and how you have configured the view. This section explains 
the common elements of the Main Window that are present in most configura-
tions of most views. For detailed information about customizing views, refer to 
Chapter 3.

The first time you use Supervisor, all its views are set to their default appearances. 
When you have successfully connected to a runtime host system, Supervisor 
displays its information in the CE View. Figure 2-3 shows the CE View with the 
system tree expanded to cluster level, with the second cluster selected. 

Figure 2-3. The Supervisor Main Window
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Supervisor Toolbar 

The toolbar provides quick access to frequently-used commands:

By default, it is visible, but you can toggle the display of the toolbar by choosing 
View> Toolbar.

If you leave the cursor pointing to a Toolbar button for a few seconds, Supervisor 
displays Tool Tips: 

Status Bar and Progress Bar
The Status Bar and the Progress Bar are located at the bottom of the Main 
Window. 

The Status Bar describes any active network-related operation, such as connecting 
to the runtime system, or updating the table of information. If the View is locked, 
it is noted in the Status Bar, since a locked Window cannot show any network-
related activities. If there is no active operation, the Status Bar remains blank.

The Progress Bar displays information about any active operation, in words, and 
with a colored horizontal bar that is filled in as the operation completes. If there is 
no active operation, the Progress Bar remains blank.

For example, as shown in Figure 2-5, while the displayed data is being updated 
with new information from the runtime host, the Status Bar displays the message 

Figure 2-4. Supervisor Toolbar



Chapter 2 Getting Started

10 Supervisor User’s Guide

DRAFT
Updating... and the Progress Bar tracks the percentage of the operation that has 
completed. 

Basic Commands and Navigation 
The left pane in Supervisor’s main window shows the Mercury architecture 
model for the runtime host system, displayed as a tree. Use the system tree to 
control what is displayed in the right pane. The right pane is a table of detailed 
information about the item selected in the left pane. 

Views, and View customizations, only affect the appearance of the right pane. You 
can control which columns are displayed in the table, and whether the Informa-
tion panel is displayed or hidden, but you cannot edit the text of these elements. 
(For details about customizing Views, see Chapter 3.)

The background colors of table rows are alternately dark and light. Selected rows 
change to a third color. The exact colors used depend on your system configura-
tion and on whether you have reset your preferences, as described in “Choosing 
Display Colors” on page 28.

Figure 2-5. Status Bar and Progress Bar

Figure 2-6. Elements of a View
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� To select multiple rows in the table:

Use Shift-Click to select contiguous rows. Click on one row, then Shift-Click on 
the last row of the desired range.

Use Ctrl-Click to select non-contiguous rows.

The information in the right pane is updated periodically when Supervisor 
retrieves new data from the runtime host system. You can control how often 
Supervisor updates data, force an update, stop an update, or lock part or all of the 
table so that it remains static. 

About Locking
Locking a row or View means that its data is not refreshed when Supervisor makes 
an update call to the runtime system and retrieves new data. For example, if 
runtime host terminates a process and reclusters its CEs but Supervisor does not 
display those changes if the corresponding row or View is locked. You can issue 
suspend, resume, kill, or debug commands on processes that are part of a locked 
row or View, but Supervisor cannot display the command’s results until the row 
or View is unlocked and updated.

Locking and Unlocking a Row
Locking a row in the table freezes the data in that row. All other, unlocked, rows 
in the table are refreshed when Supervisor updates the display.
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For example, if you are in the CE View with a process selected in the system tree, 
you can lock the process by clicking in the Lock column of the its row, as shown in 
Figure 2-7:

The row remains locked, even if you select a different element in the system tree.

� Other ways to unlock a row:

• Click in the Lock column to un-check it.

• Click on the row to select it, then choose Edit > Unlock Item.

• Click on the row to select it, then right-click to bring up the context-sensitive 
pop-up menu, then choose Unlock.

Locking a View
When you lock a View, all rows of the table and the Information panel are frozen, 
and the data is not updated. The system tree and the table are greyed, as shown in 
Figure 2-8. You can change Views, but you cannot use the system tree to change 
the items displayed in the table. The Lock View commands are toggles; whenever 
you use them, they change the View to the opposite state.

� To lock/unlock a View:

Click the Lock icon in the Toolbar.

Choose View > Lock View.

Figure 2-7. Locking a Row
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Using the System Tree 
The system tree displays the Mercury architectural model of the runtime host 
system. You can expand and contract the tree by clicking on an item’s handle, as 

Figure 2-8. A Locked View
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shown in Figure 2-9. The detail shown in the right pane table corresponds the 
item selected in the system tree.

Figure 2-9. The System Tree
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When you select an item in the system tree, Supervisor displays information 
about the item in a table in the right pane, as shown in Figure 2-10.

� To de-select an item:

Click on another item to select it. 

An item is always selected in the system tree.

� To expand the system tree:

 Click the box-and-cross handle to the left of the item, or double-click the 
item, which also selects it.

 The right pane displays information at the level of the selected item.

� To contract the system tree:

Click the box-and-dash handle to the left of the item, or double-click the item, 
which also selects it.

 The right pane displays information at the level of the selected item.

Figure 2-10. CE View of Runtime Host
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Comparing Different Elements of the Runtime Host
Only one selection in the left pane can be displayed in the right pane. To compare 
different elements of the Mercury model for the same runtime host system, open 
another Supervisor window and navigate to the appropriate element. You can 
place the open windows side by side on your screen for easy visibility. You can 
open two windows that display the same process or CE in different Views. 

Note that selecting objects or customizing the display affects only the Supervisor 
window in which you issue the commands. No other open Supervisor windows 
are changed in any way.

Using the Views 
Each View organizes information about the runtime host system to emphasize 
one level of the system hierarchy: Clusters, CEs, or Processes. The exact display of 
this information depends on how the View has been customized, and on which 
item has been selected in the system tree.   

Select this in the 
system tree...

to show details about...

RuntimeHost ID The Runtime Host: how many clusters are configured, how 
many CEs are present, how many processes are running, as 
shown in Figure 2-10.

a cluster The Cluster: ID of the Name Server on the runtime host, the 
number of CEs in the selected cluster, and the time elapsed 
since the Name Server was initialized

 a CE The CE: its ID number, the type of processor, its state, the 
number of processes running, and the number of images 
loaded

a process The Process: its ID number, its state, the image’s ID number, 
the image’s file name (but not its full path), and the current 
program counter value
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Changing Views

To change to a different View, click the appropriate tab, as shown in 
Figure 2-11:

CE View
The CE View shown in Figure 2-12, displays detailed information about the 
selected CE.

Figure 2-11. View Tabs

Figure 2-12. CE View, CE selected

To display details about... In the system tree, select the...

All CEs in the runtime host system Runtime host system 

All CEs in a specific cluster Cluster

A specific CE CE

The host CE of a specific process Process
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Cluster View
The Cluster View shown in Figure 2-13 displays detailed information about the 
runtime host configuration.

Process View
Figure 2-14 and Figure 2-15 show how the Process View displays different 
information when the runtime host is selected, and when a cluster is selected.

Figure 2-13. Cluster View, Runtime Host Selected

To display information about... In the system tree, select the...

Its host cluster Process

Its host cluster CE 

The selected cluster Cluster 

All clusters in the system Runtime host system 
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Figure 2-14. Process View, Host Selected

Figure 2-15. Process View, Cluster Selected

To display information about... In the system tree, select the...

The selected process process

All processes running on the CE CE 

All processes running on the cluster cluster

All processes running on the runtime host 
system 

runtime host system 
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 Exiting Supervisor

� To close the active window:

Choose File > Close. 

If this is the only open window, this command also exits Supervisor.

� To exit Supervisor:

Choose File> Exit. 

Note: If the active window is the only open window, File > Close exits the application. 

When you exit Supervisor, it saves your preferences and View customizations. If 
you have several open Supervisor windows with different settings, it saves your 
preferences and customizations from the window from which you issued the Exit 
command (or from the last window you close).

Quick Reference to Supervisor Menus
The Supervisor menu bar contains these menus: File, Edit, View, Process, and Help. 
The following sections show each menu (with keyboard shortcuts and 
mnemonics for its commands) with brief descriptions of its commands.

File Menu

Edit Menu

Use the commands in the File menu to open and close Super-
visor windows, connect to and disconnect from a runtime 
host, and to exit Supervisor.

Use the commands in the Edit menu to control the update 
interval, to set preferences for screen appearance and utilities, 
and to select all items in a View. You can also lock and unlock a 
selected item; a locked item is not updated when Supervisor 
refreshes the data from the runtime host.
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View Menu

Process Menu

Help Menu

Context-Sensitive Pop-Up Menus
Right-clicking on a selected item in the Main Window typically displays a 
context-sensitive pop-up menu, as shown in Figure 2-16 and Figure 2-17. These 
pop-up menus provide another way to issue Supervisor commands. 

You can right-click on a selected element in the system tree or on a row in the 
table. Only the commands that can operate one entity at the level of the selected 
element are active; the rest are greyed. For example, if you right-click on a cluster, 
all the commands in the pop-up menu are greyed. There are no Supervisor 
commands that treat a cluster as a single entity. 

Since an object cannot be simultaneously selected in the system tree and in the 
right pane, the scope of the command is unambiguous. The command affects the 
only the selected item.

Use the commands in the View menu to toggle the display of 
elements in the Supervisor Main Window, to customize any of the 
three views, and to lock and unlock Views.

Use the commands in the Process menu to manage one or more 
selected processes, or to launch the MULTI debugger. Suspend, 
Resume, Kill, and Debug all take precedence over any update calls 
to the runtime system.

Use the commands in the Help menu to view more information 
about Supervisor. If you selected an HTML browser in the Edit > 
Preferences dialog box, or if your development host has a default 
browser configured, Help > Contents opens the browser and the 
online version of this User’s Guide. Help > About displays informa-
tion about this release and version of Supervisor.
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You can also use a pop-up menu to sort the information in a table with respect to a 
selected column, as shown in Figure 2-17. Only the active Supervisor window is 

Figure 2-16. Context-sensitive pop-up menu
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affected by this command. Any other open Supervisor windows remain 
untouched.

Disconnecting from a Runtime Host System
� To disconnect from a runtime host system, do one of the following:

Choose File > Connection... and click Disconnect in the Connection dialog box.

Click the Disconnect button in the Toolbar.

Opening More Supervisor Windows
� To open a new Supervisor window:

 Choose File> New Window or type Ctrl-N.

An identical Supervisor window appears on top of the original one. They are 
connected to the same runtime host, but otherwise behave independently. 
The new window is opened with the same configuration as the original 
window, but any new settings or changes in locked/unlocked elements affect 
only the window in which they are issued.

Figure 2-17. Context-sensitive pop-up Sort menu




